Halfspace Analysis

Introduction

The following tutorial describes the basic workflow of the task “Halfspace”. Guided by the task, all necessary input will be defined. The first example is taken from the HASE manual. For further descriptions and examples please also refer to the HASE manual. After working through these tutorials, the user should be able to use this task for further halfspace calculations.

Note

To understand this tutorial, a basic knowledge of the SSD is required. We recommend to see our online introduction videos.

Download Project Files

You will find the data files on our ftp-server.

Note

You need the current SONAR login and password to get access to the files.

SSD-Task Halfspace

Task Content

This task allows the user to perform a simple foundation analysis using the halfspace substructure method. For further information and description, please refer to the handbook HASE.

Note

In the basic program version, only halfspace problems with plane slab structures can be processed. Halfspace analysis for three-dimensional systems, in addition to the substructure techniques, is available in the extended program version.

A linear elastic stiffness matrix will be generated for the halfspace processing, therefore a superpositioning is possible.

A combination with the other FEA programs is also possible.

General Description

The program determines a stiffness matrix for any structure size. These structures can be assembled either from Finite Elements or described analytically e.g. as an elastic halfspace with appropriate soil parameters. Soil parameters will be defined by bore profiles, either within a new task “Bore Profile” or directly inside the task “Halfspace Calculation”. Both tasks can be added by using the context menu inside the sidebar with the right mouse click and the command “Insert Task”.

Note

The bore profile task must be added before inserting the task “Halfspace Calculation”.

../../_images/task-lib.png

The dialogue based input guides the user through the task and the following examples will explain the workflow. For further information and explanation we refer you to the handbook hase_1.pdf available via the Help menu documentation. Additional examples are available inside the program directory:

Note

More numerical examples are available. Please go to TEDDY menu Help and select “Examples... > hase > english”.

Example 1: Raft Foundation

Project Description

The following example, a flat slab raft with the stiffness coefficient method, was taken from the HASE handbook. Wall loads should be applied as untensioned loads on the bottom plate with the dimensions 6m x 10m in plan. The bottom plate will have a thickness of 300 mm.

../../_images/exp1-system.png

Start a new project

Start new SSD project as usual with Eurocode EN 1992

Define Materials

Define the materials according the following table.

Number Material Strength
1 concrete C 20/25
2 reinforcement steel B 500B

Define Bore Profiles

The soil parameters will be entered using the task “Bore Profile”. First you must insert a new task “Bore Profile” in your project. Use the context menu with the right mouse click and select the command “Insert Task”. Now select the task “Bore Profile” from the task library. Next you must create a new bore profile in your project. Again use the context menu with the right mouse click on task “Bore Profile” and select the command “New”. For this example we will use only one profile. Input the number and name of the bore profile, then select the option “Soil Layer Profile” from the bottom of the “General” tab.

Only a single bore profile will be defined. Position of profile in global coordinates: x = 0.0 m, y = 0.0 m and z = 0.0 m

Layer Number Ordinate from - to [mm] Constant Stiffness k0 [kN/m²]
1 0 - 1.200 5.000
2 1.200 - 3.200 12.000
3 3.200 - 5.200 9.000
4 5.200 - 10.000 90.000
5 10.000 - 50.000 200.000

../../_images/bore01.png

Next switch to the tab “Layer Profile” and generate new layers with the properties listed in the table above. With the button “New” you may create a new layer. Insert ordinates and stiffness parameter according your requirements. If you click in the picture on the right hand side of your dialogue you may select the different layer directly and may change the layer properties. In our example we use a constant stiffness for each layer.

../../_images/bore02.png

Note

In cases where more than one bore profile will be defined, an interpolation will start automatically for the calculation. Manual specification of the weight factor is possible for use in the interpolation.

System Generation with Task “Text Interface for Model Creation”

The very simple geometry will be defined using the task “Text Interface for Model Creation”. Add the task to the Task Tree and open with a double-click, then add the following input:

+PROG SOFIMSHA $ Text Interface for Model Creation
HEAD Example 1 bottom plate
SYST init
ECHO FULL YES
NODE NO    X     Y
      1    0[m]  0[m]
      2   10[m]  0[m]
      3    0[m]  6[m]
      4   10[m]  6[m]
GRP 0
QUAD N1 3 1 2 4 M 8 N 10 MNO 1 MRF 2 T 0.30[m]
END

Note

A powerful generation algorithm is provided with the command QUAD inside the PROG SOFiMSHA. On the basis of 4 nodes and subdivisions in two directions, you can create a regular mesh.

After finishing the input, start the calculation for this task using the right click menu “Calculate” command.

Load Generation with Task “Text Interface for Loads”

LC Number Title Loads
1 Wall Load g1 = 70,00 kN/m

A wall load of 70 kN/m is applied along all perimeter edges. To do this, add and open the task “Text Interface for Loads” and add the following input. In general you start with the definition of actions and go on with the loading. In this case we only have one Action Q and one loadcase LC 1. To deal with this basic principle we first define the Action Q and then the loadcase 1, which is assigned to Action Q:

 +PROG SOFILOAD $ Text Interface for Loads
 HEAD Text interface for Loads
 $ Actions
$ ACT G   $ dead loads
 ACT Q   $ live loads
 $ Load cases
 $ self weight will be ignored in this case
 LC 1 Q TITL 'Variable Load'
 LINE  REF  TYPE P1 x1      y1      P2 x2      y2
       auto  PG  70 0.10[m] 0.10[m] 70 9.90[m] 0.10[m]
       auto  PG  70 0.10[m] 0.10[m] 70 0.10[m] 5.90[m]
       auto  PG  70 0.10[m] 5.90[m] 70 9.90[m] 5.90[m]
       auto  PG  70 9.90[m] 0.10[m] 70 9.90[m] 5.90[m]
 END

After finishing the input, start the calculation for this task using the context menu with the right mouse click and select the command “Calculate “Text Interface for Loads” command.

Task Halfspace

Next insert a new task “Halfspace Calculation”, move it to the group “Linear Analysis” and open it with a double-click.

../../_images/exp1-half01.png

Starting with the tab “General” select the listed loadcase and bore profile. By default all load cases and bore profiles will be selected automatically. You may also add or modify the bore profiles here. In this case select a bore profile and click on the button “Edit”.

In our example now we use the default settings of tab “General”.

Note

The task “Bore Profiles” should be added, defined and calculated in advance, which makes it easier to handle modifications.

The tabs “Text Output” and “Graphical Output” are the same in nearly every SSD-task. Change the settings for selecting the amount of output.

For the stress distribution in different depths you may use the tab “Soil Response”. Inside this tab a table of evaluation levels is defined. For every level and every evaluation load case the results will be saved in new result load cases starting with number 8001. You may also select the option to save an external volume structure containing the half space results.

../../_images/exp1-half02.png

When the option “Process immediately” is ticked, the calculation is started automatically after finishing the input with “OK”. Normally we recommend to use this option. The task halfspace creates an input data file. You may check the numerical input generated automatically by the task using the command “Text Editor” from the context menu with the right mouse click on the task “Halfspace Calculation”. The input looks as follows:

$ Automatically generated by HASE V(11.5-33) 17.07.2015 09:40:38
$ Attention: Changes will be overwritten if the task is opened again!
+PROG HASE urs:15.1 $ Build stiffness of soil
HEAD Build stiffness of soil
PAGE UNII 0
HALF TYPE CONS FAKX 0.40 FAKY 0.40 Z 0.0 $ Bore profiles interpolation method ...
BORE 1
PLAS PMAX 5000.00 $ Maximum bedding pressure for raft
END

+PROG ASE $ Analyse load cases
HEAD Analyse load cases
PAGE UNII 0
CTRL OPT SOLV VAL - $  Solution of the system
#define ase_hase
  SYST PROB LINE
  STEX $ external stiffness from program HASE
#enddef
#include ase_hase
LC ALL
END
END

+PROG HASE  $ Evaluate soil response
HEAD Evaluate soil response
PAGE UNII 0
LC ALL
SELP ZR 1 $ Depths for storing the results
SELP ZR 2 $ Depths for storing the results
SELP ZR 3 $ Depths for storing the results
SELP ZR 5 $ Depths for storing the results
SELP ZR 10 $ Depths for storing the results
SELP ZR 15 $ Depths for storing the results
SELP ZR 20 $ Depths for storing the results
SELP ZR 30 $ Depths for storing the results
SELP LCST 8001 $ Loadcase for results
SELP BRIC "$(project)_bric" DX 1 DY 1 HMIN 1 $ Generate volume system ...
END

The above input blocks were generated by the task “Halfspace Calculation”; PROG HASE; PROG ASE and PROG HASE. The first block calculates the halfspace stiffness, which will be used as an external stiffness matrix in the following PROG ASE, function STEX. The module ASE uses this external stiffness matrix to analyse the structure and loads. After that an evaluation of the bedding stresses in different levels are perforemd again by the module HASE.

Warning

Changes made in the text editor will be overwritten if the task Graphical User Interface is opened again.

Results

The resulting bedding stresses in the two main cuts are printed below. As you can see the maximum stresses are located below the outer wall.

../../_images/exp1-results1.png

Please note the beddings stresses in the middle of the plate are smaller using the Stiffness coefficient method instead of using the Winkler assumption.

Example 2: Pile Foundation (2D)

Piled foundations can also be analysed using the halfspace method. In this case special halfspace piles are necessary. The method for dealing with these is explained in the following example.

Project Description

The geometry is printed below. The 4 piles have a diameter of 800 mm and a length of L = 8000 mm. The pile cap thickness is d = 1000 mmm

../../_images/exp2-system.png

Start a new project

To start this example please create a new 2D slab project inside the SSD. Note that your choice of design code will affect the drawing units. As a design code we select Eurocode EN 1992.

Define Materials

Define all materials according the following table:

Number Material Strength
1 concrete C 30/37
2 reinforcement steel B 500B

Define Cross Section

Define the cross section according the following table:

Number Title Dimensions
1 Pile diameter 800 mm

../../_images/exp2-sect.png

Define Bore Profiles

Only a single bore profile will be defined. Position of profile in global coordinates: x = 0.0 m, y = 0.0 m and z = 0.0 m

Layer Number Ordinate from - to [mm] Constant Stiffness k0 [kN/m²]
1 0 - 2.000 1
2 2.000 - 5.000 50.000
3 5.000 - 20.000 80.000

The input of bore profile properties works the same way as described in example 1.

System- and Load Definition with SOFiPLUS(-X)

System- and load generation will be done with the task “GUI for Model Creation (SOFiPLUS(-X))”. The program SOFiPLUS(-X) will now be opened in a new window. Two load cases containing vertical forces and moments will be applied on this pile construction.

System Generation

For the pile cap, draw a rectangle of dimensions 4m x 4m and create a structure area with a thickness of 1000 mm by using the command “pick point in area”. Add the variable load in LC 2 of 10kN/m2 at this stage in the loading dialogue window that appears.

Then create four structure points at coordinates (in [m]) (1.0,1.0), (3.0,1.0), (1.0,3.0) and (3.0,3.0) to model the halfspace piles using the command “Point”. Add the following input in the tab “ Halfspace pile element” before placing the structure points. Select the cross section that you created in the SSD.

../../_images/exp2-point.png

After placing the structure points the model should look like this:

../../_images/exp2-area.png

Loads

Now we add the remaining loads.

LC Number Title Loads
1 Load case 1 PG = 500 kN, MX = 50 kNm
2 Load Ccase 2 PG = 500 kN, MX = 100 kNm, g =10 kN/m²

The area load of 10 kN/m² in LC 2 was added directly with the creation of the structure area and will already appear in the Loadcase Manager. You will need to create LC1 and its corresponding G action in the Loadcase Manager tool. The point loads and moments will be added by using the command Free Loads “Point Load”. All Point Loads are to be applied to the centre of the slab. Four Point Loads will be generated; LC1 load, LC1 moment, LC2 load and LC2 moment. The load values are as per the table above. You may find it useful to draw a line across the slab to help with finding the centre position.

../../_images/exp2-load.png

System and load generation is finished now. Please save your project and select the command “Export” to start the meshing and save all information in the CDB. Now all work is finished inside SOFiPLUS(-X),you can close it and switch back to the SSD window. The system can be shown inside the SSD window inside the ANIMATOR view.

../../_images/exp2-animator.png

Task Halfspace

Now add the task “Halfspace Calculation” and open it for editing. Previous input regarding load cases and bore profiles are gathered automatically and shown inside the dialog window.

../../_images/exp2-half01.png

For general cases, no further input is required. To change the amount of output use the tabs “Text Output” and “Graphical Output”. When all input is finished, choose the option “Process immediately” and the calculation will start when the OK button is pressed.

Note

The halfspace piles created in SOFiPLUS(-X) are saved directly in the CDB. If you open the task “Halfspace Calculation” with the Text Editor the sentences PILE are missing in the first PROG HASE block.

Once the Halfspace Task has been run, a representation of the of the piles are shown in the ANIMATOR.

../../_images/exp2-animator2.png

Evaluation Results

After the calculation you will get the following results (from Report Browser - HASE):

../../_images/exp2-results1.png

The pile forces were ploted in the chapter ” Calculate Halfspace Forces”.

../../_images/exp2-results2.png

The bedding stresses are saved in the load cases 8001 ff for different depths. Use WINGRAF to visualize the stresses. Pile forces (total force, friction force, force in pile foot) are also printed. A simple check with the loads of LC 2 gives a total pile force of:

\[max |P| = \frac {10.0 \ [kN/m²] \cdot 16,0 \ [m²] + 500.0 \ [kN]}{4} + \frac {100,0 \ [kNm]}{2 \cdot 2.0\ [m]} = 190 \ [kN]\]

The part of skin friction at the load transfer will be used as defined in SOFiPLUS(-X).

Example 3: Pile Foundation (3D)

The same project from example 2 will be used to introduce the extended piles.

Project Description

The geometry is printed below. The 4 piles have a diameter of 800 mm and a length of L = 8000 mm. The pile cap thickness is d = 1000 mmm

../../_images/exp2-system.png

We will use the same project as described in example 2, except we need now a 3d FEA system.

Start a new project

see description in example 2.

Note

You may use the function “copy as” from the SSD Menu > file and save the project exp_hase_2.sofistik with a new name, e.g. exp_hase_3.sofistik. Simply go into the “System Information” dialogue and change the system setting from 2D into 3D. Geometry, bore profile, cross sections and loads remain the same as before.

Define Materials

see description in example 2.

Define Cross Section

see description in example 2.

Define Bore Profiles

see description in example 2.

System- and Load Definition with SOFiPLUS(-X)

The only thing you have to change is to delete the structural points and replace them with 8 m long centric beam elements, facing downwards in global direction.

../../_images/exp3-area.png

The difference to the halfspace piles is now the fact, that you have real beam elements in your system. System and load generation is finished now. Please save your project and select the command “Export” to start the meshing and save all information in the CDB. Now all work is finished inside SOFiPLUS(-X),you can close it and switch back to the SSD window. The system can be shown inside the SSD window inside the ANIMATOR view.

../../_images/exp3-animator.png

Task Halfspace

No changes were made. Use the same settings from example 2.

Evaluation Results

After the calculation you will get the following results (see Task “Plot Results”): The first plot shows the distribution of the normal forces inside the extend piles.

../../_images/exp3-results1.png

The second plot shows the axial pile bedding forces. You can see the effect of the pile bedding, which is very small in the upper part of the pile, then you have a section with axial resistance, like a skin friction effect and at the pile foot you see a large pile foot supporting force.

../../_images/exp3-results2.png

The bedding stresses are saved again in the load cases 8001 ff for different depths. Use WINGRAF to visualize the stresses. With the extended piles it is possible to make a design for these pile elements directly.

Non Linear Effects

For nonlinear effects please add these properties inside the
  1. layer profile of task “Bore Profiles”
../../_images/exp3a-bore.png
  1. task „Halfspace calculation“. There you must define the non linear bedding effects and also a number of iterations.
../../_images/exp3a-half.png

After the calculation you will get the following results, which are of course different from the linear analysis (see Task “Plot Results”): The first plot shows the distribution of the normal forces inside the extend piles.

../../_images/exp3a-results1.png

The second plot shows the axial pile bedding forces.

../../_images/exp3a-results2.png

From both plots you can see the nonlinear effect of the soil acting on the pile elements.